Email Verification Message Sent

Incident Report for EU Production Cloud

Update

We are continuing to work on a fix for this issue.
Posted Nov 12, 2025 - 15:26 UTC

Identified

You may have received an email from Plume earlier today that was sent in error. Please rest assured it was simply a misfire, not a security or data issue.

No action is needed on your part, and your information remains completely secure.

We know messages like this can cause concern, and we appreciate your understanding. Our teams have already corrected the issue and are ensuring it doesn’t happen again.

Thanks for your patience and for being part of the Plume community.
Posted Nov 12, 2025 - 10:32 UTC