Cloudflare Outage impacting Plume services

Incident Report for EU Production Cloud

Resolved

It has been confirmed that the incident is resolved and at this time all Plume functionality is back to normal.
Posted Nov 18, 2025 - 20:04 UTC

Monitoring

A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 14:53 UTC

Identified

Some Plume services, including password reset, verification emails, and OpenSync.io, are currently experiencing temporary disruption due to the global Cloudflare outage. Our team is actively monitoring and will notify when resolved.
Posted Nov 18, 2025 - 14:22 UTC