Delays in receiving authentication emails

Incident Report for EU Production Cloud

Resolved

All authentication emails for mobile app login are back to real-time sending. Some users may receive multiple emails if they requested their login links more than once. Plume continues to monitor the system closely.
Posted Nov 16, 2025 - 21:28 UTC

Investigating

Some Plume app users have reported delays in receiving authentication emails for mobile app login.
Our teams are actively working to resolve the issue.
Posted Nov 14, 2025 - 15:17 UTC